An error occurred while saving the commentMichał Kościelniak commented
Yes please. I can't believe it's not there. We are experiencing similiar issue - our db names follows naming convention so that its name is just a GUID. If we could add alias to the collection it would be great. It could be very simple, for instance display aliast in parenthesis, so the name would be:
CollectionName(Alias). The alias just need to be visual feature helpiing to navigate through the IDE.